XenForo 1.5 is no longer in active development

Discussion in 'XenForo' started by R0binHood, Dec 11, 2018.

  1. R0binHood

    R0binHood Habitué

    1,223
    432
    +953
    • Agree Agree x 2
    • Informative! Informative! x 2
    • List
  2. sanction9

    sanction9 Enthusiast

    200
    58
    +123
    :werd:

    RIP XF1.5
     
  3. R0binHood

    R0binHood Habitué

    1,223
    432
    +953
    The King is Dead! (XF 1.x), Long live the King! (XF 2.x)
     
  4. southernlady

    southernlady Coder/Designer

    2,408
    722
    +189
    If TAZ is like me, it's gonna take time to do that.

    But I have a boatload of add ons, some no longer used. Uninstalling them first and then trying to find 2.x versions of the ones I know I am using.
     
  5. R0binHood

    R0binHood Habitué

    1,223
    432
    +953
    John Cena would like a word...

    [​IMG]
     
  6. Mouth

    Mouth Enthusiast

    193
    93
    +108
    Effectively meaning any add-on's not updated to XF2 versions within the next 3 months have to be treated as abandoned.
     
  7. southernlady

    southernlady Coder/Designer

    2,408
    722
    +189
    Which is why I’m working on cleaning up my 1.5x version so I can prepare it for upgrade soon.
     
  8. zappaDPJ

    zappaDPJ Administrator

    6,697
    1,342
    +5,279
    I would have liked to have seen a commitment to release security updates for longer than a year. I'm sure there will still be people running on 1.5 long after that.
     
  9. wakey

    wakey Aspirant

    14
    3
    +8
    That’s one of the things I like about vBulletin, they may stop developing their older versions but you still get security patches years later. Moving to the latest version can be a major task that can mean removing features or discarding data as an alternative plugin can’t import from a previous version and people shouldn’t basically be forced to do so for security reasons. Crazy thing is if anything you would say vBulletin is the one that could justify doing this as you are paying a one off fee, when there is an ongoing fee there is little reason why security Patches couldn’t be supplied as long as the licence is still active
     
  10. Alfa1

    Alfa1 Administrator

    3,795
    1,702
    +2,663
    I would expect that this leaves those on xf1 with no reason to renew their license after xf1 goes EOL.
     
  11. we_are_borg

    we_are_borg Administrator

    5,316
    1,417
    +2,099
    No a smart person renews when he needs 2.1 or later so he saves some cash.
     
  12. Paul M

    Paul M Limeade Addict

    3,788
    1,627
    +2,210
    I have never understood the rush to update - the software isnt going to stop working in 6 months.

    "If it aint broke, dont fix it."
     
    • Like Like x 1
    • Agree Agree x 1
    • List
  13. R0binHood

    R0binHood Habitué

    1,223
    432
    +953
    “If there’s new features, upgrade so you and your users can enjoy them” ;)
     
  14. wakey

    wakey Aspirant

    14
    3
    +8
    I would say the biggest thing is you have 6months to try and get an upgrade done with the minimum of distruption to the user experience. Where as if you leave it and there is a security issue after 6 months then to secure the software you then have to rush the upgrade to secure the forum
     
  15. Alfa1

    Alfa1 Administrator

    3,795
    1,702
    +2,663
    All the while most addons have not been updated yet, which means loosing features. Some of which are major or may even essential depending on your current configuration. If you run a bare bones install then you are certainly right. If not then it becomes more complex. I do not see an upgrade path anytime soon.
     
  16. sanction9

    sanction9 Enthusiast

    200
    58
    +123
    Out of curiosity, what addon's are you using that you deem indispensable that aren't available for 2.0? Because I use probably more addon's than most people, or than a lot of them, and I can't think of anything off the top of my head that I haven't been able to replace with one 2.0 addon or another. (Although granted I'm probably paying more now!)
     
  17. Alfa1

    Alfa1 Administrator

    3,795
    1,702
    +2,663
    • Social Groups is the most problematic one as it took 4 years to become somewhat usable for xf1. Fat chance on social groups becoming a reality anytime soon. This needs a new developer offering a viable solution.
    • Four Oh Four. This addon has a mass of 301 redirects in it. It needs to be replaced but if nothing appears then I can have this done.
    • Live Feed. This addon is a game changer. Loosing it would be a serious downgrade. Maybe Xon will add it to his live content addon at some point.
    • Events by NixFifty
    • Tickets by NixFifty
    • Some private major addons that are already ported to XF2 but need to have important functionality added. This will take some time. These content types are more important than forum.
    • Meta Mirror
    • Master Badge. Its debatable if this indispensable or not. I could do without it for some time even though there would be some fall out.
    • I need a fix for bd attachment store on xf1 for 140k broken attachment links before I can upgrade.
    • And I need to rewrite my advanced reputation system and my registration essentials for XF2.
    • Thread ratings. This one I will likely integrate into my reputation addon if I have it rewritten for XF2.
    I run about 85 other addons that I can replace or do without on xf2.
    Meanwhile I am happily having functions created for XF1, until I see a viable upgrade path.
     
    Last edited: Jan 6, 2019
  18. Karll

    Karll Adherent

    349
    117
    +155
    6 months is quite a short time. No one should have to upgrade to 2.0 which adds very little over 1.5, and of course is incompatible with 1.5 add-ons.

    I think when 2.1 is finally released, that would be the right time to start talking about EOL for 1.5, and even then 6 months is not nearly long enough.
     
  19. Chris D

    Chris D XenForo Developer

    766
    1,022
    +1,747
    It’s 12 months if you consider security updates until December 2019 and bear in mind there’s hardly ever any maintenance releases for 1.5 as it is.

    It’s over 24 months if you count all of the time 2.0 has been available. Surely shouldn’t be a surprise that at some point after the release of 2.0 that we would call time on 1.5 and a 2 year period for that seems incredibly reasonable IMO.
     
  20. we_are_borg

    we_are_borg Administrator

    5,316
    1,417
    +2,099
    31 December 2019 for security updates is fair. I would have like to see 12 months after 2.1 release so that people would have a full year to upgrade from 1.5.x to 2.1 that would have been sweet and very very reasonable.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.