WoltLab Suite 3.0 Released

Discussion in 'WoltLab Burning Board' started by WBB, Jan 12, 2017.

  1. ChrisTERiS

    ChrisTERiS Developer

    598
    212
    +349
    Someone of you or the anonymous (really why anonymous?) replier to my ticket 5190 at 27 Feb 2017 must be wrong. The reply that I got was:
    Even if I replied to him that currently the only that I need is upgrade to 4.1 as none of the plugins that I use are compatible with 5.0, the reply was the same "You must upgrade to 5.0". So where is the option to upgrade to 4.1 as you wrote before?

    Edited: When I upgraded my xF license, they didn't asked me to pay for all intermediate versions. And this is the logic. Why to pay for versions that I never downloaded, never used, and never got support for them? Have I downloaded, used, supported for your 4.1 version? No.

    Edited 2: The same with IPB. My license expired at January 2015. They didn't asked me to pay for the period Jan 2015-Jan 2017. They ask $95 for 6 months ahead.
     
    Last edited: Mar 18, 2017
  2. dtdesign

    dtdesign Developer

    569
    287
    +658
    Both replies have the proper signature appened to the message, may I assume that you are referring to a different ticket id?

    Licenses can only be updated to the latest version at that time, but we do grant a discount for licenses that have access to more recent versions. The more recent the version, the higher is the discount.
     
  3. ChrisTERiS

    ChrisTERiS Developer

    598
    212
    +349
    You're right, my apologies. But I was expecting to see a name below the message and not below to my original message.

    What kind of discount is if I need to pay $69 for renewal while a new license costs $89?.
    But again you avoid to comment the comparization with other forum software. None asks to pay for versions that never downloaded, never used, never got support.

    Can you give me a logic explanation on this? I don't argue with you. Just try to understand. Don't you know that is like punishing your old clients? I bought WBB for first time at January of 2011. 6 full completed years. Can't say that I follow all renews. But I paid some of them. I paid without to use anything at anytime. I never used WBB not because I didn't liked it but because was difficult to know to use it after so long use of vBulletin. For the same reason I never used IPB, for the same reason that only now I'm trying to use xF. But I paid to Woltlab and to many 3nd party coders and designers (even your nickname reminds me a style that I bought) with lot of money. So, sorry, that "pay $69 for renewal, instead of $89 of new", appears like punishment.
     
  4. Jim McClain

    Jim McClain Senior Citizen

    1,972
    832
    +636
    I wish I could get punished with a 22.5% discount for everything I buy. :(
     
  5. ChrisTERiS

    ChrisTERiS Developer

    598
    212
    +349
    Depends on the calculation. Yes, 22.5% discount appears to be a good deal to buy something new. In this case is $20. But what if you already spent $750+ for something that you never used. Haven't bought only the forum, but almost all their addons. Minus filenabe. I bought 10+ AddOns and I paid for them 2 renewals. I've paid for 3 custom themes. Now, its up to you to re-calculate.
     
  6. Musika

    Musika Aspirant

    32
    8
    +8
    As you are trying to compare two different renewal-payment-systems, you can't get an explanation for one system, using the logic of the other system. You have to calculate yourself if on the long run, the one or the other renewal-system seems fair and good to you. Both have their pros and contras. Only you can decide if one or both are good for you.

    You don't like one, then let it go. Your thoughts on how logic the one or the othe is, won't change either the one or the other company in their renewal-payment-system. So... take it or not, you can't change it ;)
     
  7. dtdesign

    dtdesign Developer

    569
    287
    +658
    The comparison is a bit off, considering that owners of a license for Burning Board 4.0 (released in Dec 2013) are receiving full update and support coverage without any extra costs. The last update to the WCF 2.0 series (Burning Board 4.0 falls into this category) was on Feb 28, which was less than a month ago, free of charge.

    This doesn't necessarily justify any price differences you might experience when purchasing an update, but this is certainly something you should add to your calculations when comparing with competitors. I guess you can sum it up as a simple upfront cost with no on-going expenses?
     
  8. Gus

    Gus Enthusiast

    158
    33
    +67
    WBB is the only forum software I've never used from an admin's perspective. It looks nice though.
     
  9. ChrisTERiS

    ChrisTERiS Developer

    598
    212
    +349
    I disagree but I accept the fact that, as buyer, I must accept your rules. I'm buying scripts since 1998. Have bought more than 200 of them. Even the fact that I've bought all Forum brands, proves it. Selling by version is something that I seen only to WBB and since 2009 to vBulletin. All other scripts are selling (renewals) by time frame (mostly 12 months, but there are also some of them for 6 months).

    And what means "by version"? Has WBB 4.1 so superior improvements to be different version than 4.0. I don't think so. At least vBulletin, which as I said since 2009 follows the same method, counts all versions starting with "4" as one version. eg 4.0.0 to 4.2.4 is the same. Actually this was their Waterloo. For 8 years now they didn't got any single cent for renewals.

    But let's make the long story short as we started being out of topic. My main question is not why you charge so much. Is not why I must pay for all intermediate version. The question is why I can't upgrade to 4.1. Currently I don't need version 5.0. Maybe it is the best forum out there. But for me is useless. I'm not operating a community but a developer's website. So mods like Shop, Tickets, Bug Tracker are very important for me. And none of them is currently working with WBB 5.0. Also my custom themes (most probably) should not work with 5.0.

    Give your clients the freedom to decide which version to use. And respect the fact that the client has (at least) the right to decide what to use and what not. So I want to use 4.1. Why you push me to pay for ver. 5.0.

    And a short underline. Have you sent any newsletter/announcement about the upcoming EOL of 4.1? No. My email on your files is current and I didn't received anything. Yes, you post it in your forums. But according to which logic clients must visit your forums to keep uptodate information. When I bought your products I gave you my email from this reason. To keep me informed for any important news regarding my order. And an announcement for upcoming EOL is important news that I need to know.
     
  10. dtdesign

    dtdesign Developer

    569
    287
    +658
    I'm sorry, but as much as I can understand your issue, I'm unable to offer you a solution.

    But then again, the same argument is valid for the license cost, what if somebody buys a license today and wants to use an earlier version only? What if they want to use a version 2 or 3 major releases back? Wouldn't it be better if they only pay a tiny fraction, because they're only using ancient versions? Even if we make exceptions here and then, there is always a case that is not covered and so on.

    PS: The ACP embeds our official twitter feed that includes all announcements regarding updates, upcoming products and EOL (Burning Board 3.x used a RSS feed instead).
     
  11. GTB

    GTB Tazmanian

    4,038
    862
    +1,045
    Your logic is flawed really. You're counting the cost into things of buying extra themes and add-ons put into the equation. But those are extra things you buy by choice really, not really part of buying the forum software itself and what that costs you per year.
     
    • Pure Genius! Pure Genius! x 1
    • List
  12. ChrisTERiS

    ChrisTERiS Developer

    598
    212
    +349
    Are you talking looking yourself in a mirror? Otherwise how to explain that you're out of topic. The reply was to the specific post of Jim McClain who wrote "discount for everything I buy". If you pay attention he is not talking for the specific forum script but, in general, for "everything he buy". That's why my reply was also in general. How much it cost to me the full package. So, please continue your walk to clouds and please let me alone.
     
    • Meh Meh x 1
    • Funny Funny x 1
    • List
  13. ChrisTERiS

    ChrisTERiS Developer

    598
    212
    +349
    There is no reason to worry, as there is no really a problem. And to be honest the only reason that I wanted ver. 4.1 is because I found a nice, Facebook style theme, that it was working only with 4.1.x. That's all. And if you read carefully my first post on this thread, I gave positive feedback for the script. My own disappointment doesn't means that changes a honest review.

    There is a big difference between "buys a license today" and "bought the license 6 years ago". Hope that you understand it. Just like vB. If someone wants NOW to buy vB3 he must pay for vB5.

    :) Sorry but I'm not using Twitter. Must have an account there years ago, but never used it.
     
  14. Jim McClain

    Jim McClain Senior Citizen

    1,972
    832
    +636
    If I had known my off-the-cuff reply was going to result in all your drama, I woulda pushed my keyboard away. "No really a problem"? Yes, really a problem. Jeez man, leave it alone. Enough already.
     
  15. GTB

    GTB Tazmanian

    4,038
    862
    +1,045
    You don't need to have a twitter account yourself. The tweets are pulled into the forum admin cp as woltlab news on updates, etc, from their account. But you can disable it if you want from being displayed. Any updates gets shown as a notification on the forum anyway pending you needing to install them.

    There is no comparison between WBB and vBulletin. Sure, Internet Brands expect people to spend what is it, 300 or 400 buying vB5 because you get the ancient vB3 and vB4 thrown in (bit of a joke that now). None of the other 3 are asking anything like that much though.
     
    Last edited: Mar 19, 2017
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.