Upgrade issue from Beta5 to RC1

Discussion in 'WoltLab Burning Board' started by bogie, Dec 15, 2016.

  1. bogie

    bogie Participant

    92
    13
    +39
    On one of the test sites we are trying we did a successful upgrade, this was via the auto system.

    However we now only get a error page message when we goto the site. This is the message

    Error

    • Error Type:

      wcf\system\exception\SystemException

    • Error Message:

      application identified by package id '0' is unknown

    • File:

      */lib/system/WCF.class.php (549)

    • Stack Trace:
      • #0 */lib/system/WCF.class.php (495):
      • wcf\system\WCF->loadApplication(wcf\data\application\Application)
      • #1 */lib/system/WCF.class.php (155):
      • wcf\system\WCF->initApplications()
      • #2 */global.php (13):
      • wcf\system\WCF->__construct()
      • #3 */index.php (8):
      • require_once('*/global.php')

    It mentions going into admin panel, however the admin panel only shows a search box, nothing else. as seen in this screen shot.
    wolter.PNG

    The front page looks like this after the upgrade.
    Capture.PNG

    Any ideas how to sort it out? Out of all the schools we are trying to get, to take woltlab on, this site is the one i have had the most trouble convincing to swap to woltlab. And until this happened it has behaved the best of all the sites.
     
  2. dtdesign

    dtdesign Developer

    569
    287
    +658
    What does the file app.config.php contain? I have a strong feeling that there is a borked PACKAGE_ID definition inside which should read "1" instead of "0".
     
  3. bogie

    bogie Participant

    92
    13
    +39
    I dont have ftp access at the moment, i should be back at a pc with access later and will check this out. Thank you for the response.
     
  4. bogie

    bogie Participant

    92
    13
    +39
    This is from the file app.config.inc.php

    <?php
    // com.woltlab.wcf (packageID 1)
    if (!defined('WCF_DIR')) define('WCF_DIR', __DIR__.'/');
    if (!defined('PACKAGE_ID')) define('PACKAGE_ID', 1);
    if (!defined('PACKAGE_NAME')) define('PACKAGE_NAME', 'WoltLab Suite Core');
    if (!defined('PACKAGE_VERSION')) define('PACKAGE_VERSION', '3.0.0 RC 1');

    There dosnt look to be a file called app.config.php
     
  5. dtdesign

    dtdesign Developer

    569
    287
    +658
    Are any apps installed or is just the Core itself? I can't really tell what causes the issue by looking at the code and the fact that it complains about a package id being 0 tells me that there is something fishy. There is only a single legitimate case where the id can resolve to zero and that is during the initial setup only (read: not including updates/upgrades!).
     
  6. bogie

    bogie Participant

    92
    13
    +39
    There are all the apps installed, i simply did a upgrade when the notice popped up. I had it running on beta5 ok, then when it showed the upgrade for RC1 i pressed it to upgrade.
     
  7. dtdesign

    dtdesign Developer

    569
    287
    +658
    Understood, will contact you through a conversation now :)
     
  8. bogie

    bogie Participant

    92
    13
    +39
    Well problem fixed!! I will be getting licenses when the main version comes out. I am not a paying customer at the moment, and yet as always the level of service and speed of response was superb.

    I like the software, but more importantly the customer service and support, is a major factor in choosing this. So i am a happy bunny once again!
     
  9. Danielx64

    Danielx64 Developer

    3,330
    607
    +1,395
  10. bogie

    bogie Participant

    92
    13
    +39
    I was up late, and as soon as the updates went live i tried to upgrade. I got the server error as per my other post, so i guess trying to upgrade 3-4 times while getting errors is not a good idea :D.

    Basically it was a bit of fluke and down to plain bad luck and me being an idiot and trying to install without knowing what a 503 was.
    I dont understand the whole thing, its a bit above my level, but i think it might also be because after the core install failed, i tried to install another app and that worked (sort of).

    Or putting it plainly........i was an idiot :D.

    But they sorted it via ftp really quickly, and didnt make a fuss about noobs messing with things noobs should not be messing with :D:D. Time to let someone who knows what they are doing, to do the tech stuff, i might tinker with the colours and that though. I mean WHAT could go wrong messing with CSS files right? :whistle:
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.