phpbb Login problem

Discussion in 'phpBB' started by SzA, Oct 27, 2004.

  1. SzA

    SzA Aspirant

    34
    11
    +0
    Ya, has anyone had this problem with the quick login script:

    You login but then it asks you to login again.. making it seem like the first login attemp didn't do anything but the fact is that it did work because it says i am logged in at the footer. So when I login again (second time) the quick login goes away and im logged in BUT now all the new unread posts are gone because of the first attemp login.

    Anyone know what im talking about.. do you think its just a cookie problem or php code?

    I have had my forums for about 9 months and never had this problem but i recently moved the quick login from the footer to the header so maybe that did something, i don't know.

    Thanks.
     
  2. fumbalah

    fumbalah Devotee

    2,062
    0
    +4
    This has something to do with the cookie settings, can you post them,(admin panel, general admin, configuration
     
  3. SzA

    SzA Aspirant

    34
    11
    +0
    Cookie settings
    These details define how cookies are sent to your users' browsers. In most cases the default values for the cookie settings should be sufficient, but if you need to change them do so with care -- incorrect settings can prevent users from logging in

    Cookie domain
    Cookie name phpbb2mysql
    Cookie path /

    Cookie secure
    If your server is running via SSL, set this to enabled, else leave as disabled Disabled
    Session length [ seconds ] 3600

    hhhmm i noticed that the Cookie Domain is blank.. i just recently got a .com domain do i have to add that?
     
  4. fumbalah

    fumbalah Devotee

    2,062
    0
    +4
    It should be,

    Cookie domain: .yourdomain.com(note the dot)
    Cookie name:leave same
    Cookie path /pathtoyourforum


    clear cookies and try logging in
     
  5. SzA

    SzA Aspirant

    34
    11
    +0
    hhmm that seemed to make it worst.. creating more problems at one point i wasn't able to login.. but i delete cookies from my site and i was able to log back in and change the settings back to the way i had it.

    its gotta be something to do with the way I and others get my site because alot of us have it bookmarked under the old address instead of the .com one i dunno its really messed up.

    thanks anyways.
     
  6. RobBaker

    RobBaker Neophyte

    6
    0
    +0
    I've never heard of such a thing. You ever get it sorted out? My biggest problem with login is that I'm unable to stay logged in once the window is closed, and sometimes even getting logged out while I'm still on the page.
     
  7. major

    major Participant

    93
    0
    +0
    hi, can i butt in on this thread.

    i am having the exact same problem on my site..

    certain members (random) get to home page...log in..then it directs em back to log in page.it is becoming very annoying.lol

    website....www.thelorrydriversforum.com

    cookie settings are as pointed out in above post

    cookie domain---- .thelorrydriversforum.com

    cookie name.....phpbb3_f1zua

    cookie path......./

    i would really appreciate some info/tips ojn how to cure this problem.

    regards
     
Verification:
Draft saved Draft deleted