vBulletin Newsletter 1.3.1

Forum Activity Newsletter

  1. djbaxter

    djbaxter Tazmanian Veteran

    10,065
    917
    +156
    The same error occurred on line 1580 of functions.php

    Changed line 1580 to (removing the ampersand from =&):

    PHP:
      $parser = new vB_BbCodeParser($vbulletinfetch_tag_list());
    So here's the updated file (which needs to be uploaded to /newsletter on your server)
     

    Attached Files:

  2. djbaxter

    djbaxter Tazmanian Veteran

    10,065
    917
    +156
    It is including latest threads from private (hidden) forums. The settings indicate that it shouldn't be doing this.
     
  3. ChrisTERiS

    ChrisTERiS Developer

    552
    142
    +306
    In all blocks (eg Important, Popular etc) or just in Latest Threads?
     
  4. djbaxter

    djbaxter Tazmanian Veteran

    10,065
    917
    +156
    I have Important and Popular disabled. Just using latest threads.

    The newsletter (just test emails so far) is including moderator only and administrator only threads, as well as members only threads.

    Ideally, I would want to be able to select the threads to draw from with a dropdown rather than all the forum IDs. In fact, I tried specifying forum IDs (from my very long list of forums) and got database errors.
     
  5. ChrisTERiS

    ChrisTERiS Developer

    552
    142
    +306
    I wrote it down for the next update.
     
  6. markoroots

    markoroots Participant

    54
    13
    +13
    Great plugin, I'm testing it but look really well done and full of useful futures. Great Chris.
    The only problem is that I'm receiving many errors in my email, all the same:
    (I have Mariadb)

    Database error in vBulletin 4.2.4:

    Invalid SQL:
    UPDATE vb4_newsletter_newsletters SET emailssent=emailssent+0 WHERE id=;

    MySQL Error : You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '' at line 1
    Error Number : 1064
    Request Date : Tuesday, August 1st 2017 @ 07:40:16 PM
    Error Date : Tuesday, August 1st 2017 @ 07:40:16 PM
    Script : http://www.sigarettaelettronicaforum.com/cron.php?rand=1501609215
    Referrer : http://www.sigarettaelettronicaforum.com/nicotina/12902-calcolo-percentuali-di-nicotina.html
    IP Address : 151.66.44.96
    Username : Non Registrato
    Classname : vB_Database_MySQLi
    MySQL Version :


    I also let you know that maybe could be useful to add an option to enable or disable the plugin that could be serve like in my case, or also try to see why also if the plugin is come disabled in the Plugin Manager it continue to stay active and send the emails I have shown you.
     
    Last edited: Aug 1, 2017
  7. ChrisTERiS

    ChrisTERiS Developer

    552
    142
    +306
    Sorry to say but this is a bug from vBulletin and not from this mod (or any other mod as I seen this in mods from other coders). When you disable a plugin (I repeat, any plugin), vBulletin does not disables the assocciated with the plugin cronjobs and continue to execute them, even these cronjobs are including in the product xml file. The only way to avoid such issues is to check if the plugin has any cronjob. They are in the folder /includes/cron/ or remove them manually from cronjob list in admincp.

    As for the error. MariaDB is not a problem. As long as is supported by vB it will works. The problem is the zero values in query and don't know how it happen unless if your system messed at that time. The variable $emailsent must be greater than 0 (at least 1) and not the default 0. That's why the newsletterid (id) is missing.
     
    • Appreciation Appreciation x 1
    • List
  8. markoroots

    markoroots Participant

    54
    13
    +13
  9. EasyEazy

    EasyEazy Participant

    56
    38
    +18
    Could you add the option of sending the information via PM to certain usergroups?
     
  10. markoroots

    markoroots Participant

    54
    13
    +13
    Many thanks Chris and EasyEazy for your tips. I had disabled the cron jobs relative to the plugin before the summer as you told me and I didn't recieve any other of those mails. Now I'm trying to make work the plugin again.
    Before to reactivate the cron jobs, I was looking to the example newsletter/email that the system create before to enable for everyone, but I'm seen that all the latins characters aren't readed and all the texts that contains these letters are not clear. In the forum the latin charcaters are working, but in the plugin not.
    What I can do to fix this problem?
    Thanks in advance.
     
  11. markoroots

    markoroots Participant

    54
    13
    +13
    Sorry, it's all ok. I have found the option where to set the characters codifing.
     
  12. djbaxter

    djbaxter Tazmanian Veteran

    10,065
    917
    +156
    Are we getting close to an update, ChrisTERiSChrisTERiS?
     
  13. markoroots

    markoroots Participant

    54
    13
    +13
    I'm trying in all way to add a banner in the header but I don't know what code to add in the tab. Can someone please give me one? Sorry but I'm not expert in coding.
    Thanks in advance
     
    Last edited: Sep 13, 2017
  14. djbaxter

    djbaxter Tazmanian Veteran

    10,065
    917
    +156
    1. I'm not currently using this product. I'd like to try it but it needs some changes before it could work for my forum.

    2. I'm not the author of the product and although I can work with PHP I'm not an expert by any means.

    3. I don't even fully understand your question. In fact, to be honest, I thought your post at https://theadminzone.com/threads/newsletter.144672/page-3#post-1103534 might have been meant for another thread.
     
  15. markoroots

    markoroots Participant

    54
    13
    +13
    Hi Djbaxter and many thanks for your answer.
    My actual problem is very simple. I have to add the html code for showing the forum logo up the newsletter email.
    For this Chris have added a usefull tab under "General Option" name "Template Header" with this description "If you want to give the look of your site to the outgoing emails, write here the HTML code for the page HEADER." I have added this code found on internet and many others but I still don't see the logo up the email sent from the plugin:

    <header>
    <figure>
    <img src="logo.png" alt="Logo" />
    </figure>
    </header>



    But unfortunally it doesn't work.
    Any tip?
     
    Last edited: Sep 14, 2017
  16. markoroots

    markoroots Participant

    54
    13
    +13
    Yes I can confirm that too me I have this problem and I have also noted that this problem come when is added some forum ids in "Popular thread forumids" or is changed the number of the "News and Annunciaments" tab.
    Maybe this could be helpful for Chris.
     
  17. djbaxter

    djbaxter Tazmanian Veteran

    10,065
    917
    +156
    Yes, for that reason I've held off exploring this any further and haven't even tried yet to customize the newsletter itself. Of ChrisTERiSChrisTERiS can update this, great. But I can't use it in it's current form.
     
  18. ChrisTERiS

    ChrisTERiS Developer

    552
    142
    +306
    The solution is very easy, and when you'll read you'll say "Dammit, was so simple".

    The code is correct. The image is correct but if you're seeing the newsletter locally. But you forgot that this email will be read at user's computer. So simple you need to add the full URL to your logo. eg. http://www.mydomain.com/images/logo.png

    That's all.
     
    • Like Like x 1
    • Appreciation Appreciation x 1
    • List
  19. ChrisTERiS

    ChrisTERiS Developer

    552
    142
    +306
    This Sunday, I'm planing to do a break on coding my own forum script, so I can work some hours to improve Newsletter. Don't know how many of your requests I'll be able to add, but for sure I'll add some of them. Expect the update on Monday 18 Sep.
     
    • Like Like x 1
    • Pure Genius! Pure Genius! x 1
    • List
  20. ChrisTERiS

    ChrisTERiS Developer

    552
    142
    +306
    djbaxterdjbaxter As I can see you're active in this thread, you also post some requests, so I'll appreciate if you waste some of your valueable time to summarize in a post all requests post by you and other members. This will saves me time for coding.

    Thank you