How to Redirect the main page to forums page?

Discussion in 'WoltLab Burning Board' started by patrocle, Jan 21, 2018.

  1. patrocle

    patrocle Aspirant

    31
    13
    +3
    Hello,
    I am trying the BB Forum script to see how it works, and i kind like it! Now, i want to have when the site load to go directly to Forums section, and after spending quite some time researching i can not figure out how to make it work.

    Any help will appreciate!
    Thank you.
    P.

    (Using, WoltLab Suite™ 3.1.0 RC 1)
     
  2. dtdesign

    dtdesign Developer

    568
    287
    +657
    I'm assuming that the CMS is installed in the (relative) root: Go to "Configuration > Packages > Manage Apps" and edit the Core app, then set the landing page to the forum list.
     
    • Informative! Informative! x 1
    • List
  3. patrocle

    patrocle Aspirant

    31
    13
    +3
    Thanks for your help!
    I think i mess up the forum now... i can't access the forum at all.
    So i went in acp, configuration,manage apps and there where to options:
    1 was for the core and the other was for the Forum.
    When i try to add to the core /forum it was telling me that was used by the forum, so i went in the sec option at the forum line (in manage apps) and there was a /forum there, so i deleted and added /1 to free up, so i can go in core and add /forum then to comeback into the sec option at Forum to delete that /1, but but adding that /1 it mess up and i can access all now, hmm
    I s there a file in FTP where a can go and edit this? /1 or... or maybe a file that i can over ride to get it to work again?
    I put little work into it to set it up and hate to do a fresh install now. And the bad part is i have not done a backup up of the forum before i edited this, hmm.

    Thanks for any help and input.
     
  4. dtdesign

    dtdesign Developer

    568
    287
    +657
    Okay, hold on a second here. First of all, randomly changing the path isn't the way to go and won't solve whatever you tried to do, so if you can tell me what you want to accomplish, I would be glad to help you.

    Second, you can always recover any path mismatches by manually navigating to the ACP of the Core or any installed app and appending acp/ to the URL, e. g. example.com/path/to/the/forum/acp
    Follow the on-screen instructions to set the correct path values again.
     
  5. patrocle

    patrocle Aspirant

    31
    13
    +3
    Hello,
    So, all was working, but while u go the www.myforum.com , it was showing the main page , i guess the new feed, so i wanted when someone comes to the forum to go directly to the forum section or forum page. That was may intention of doing.
    But i had not a clue by changing the path in core to "forum" and then the Second option under neat to path "1" (just temporary) will screw all the forum up.

    Right now i can access noting...no admin back end and no main site! hmmm.
    I guess i mess up really bad this time.
     
  6. patrocle

    patrocle Aspirant

    31
    13
    +3
    Some how i manage to fix the forum back the way it was before.
    I went in the database and changed back, to /forum/ on sec option, and on the core to /

    Now i am back at figuring it out how to pointed to go directly to my forum page , when i go www.mysite.com

    from http://mysite.com/forum/ to http://mysite.com/
     
    Last edited: Jan 22, 2018
  7. patrocle

    patrocle Aspirant

    31
    13
    +3
    Not sure exactly what i did, but is now going to forum directly when i go to main domain www.mysite.com
    I have Pm U.
    Late here, long day tomorrow.

    Thanks for help!
    P.
     
Verification:
Draft saved Draft deleted
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.