Help! My forum has vanished from Google's rankings

Discussion in 'Forum SEO' started by Horizon, Jul 20, 2017.

  1. Horizon

    Horizon Aspirant

    40
    13
    +34
    On the 1st June I switched my forum software from vb5 to woltlab.

    Even though my forum was only 5 months old then, when searching for certain phrases like "politics forum uk" my forum had reached page 3 of Google's results and sometimes right before the switch was appearing on page 2 too.

    I have some new threads and posts everyday with a total of over five thousand posts in total on my forum, so it's hardly a empty site, yet since the software switch my forum has completely vanished from search engines results.

    I don't know what to do. I have no tech skills to employ tricks to improve SEO and I don't know where the problem lies.

    On the day of the forum switch, I did ask my host to block certain bots from accessing my site like hrefs, which I had read can be malicious. Was this this a good idea? There is still a google bot on my site at most times and a Bing bot too, so they don't appear to be blocked.

    Any help or suggestions would be most be appreciated. My forum is getting zero publicity or new members from search engines, as my site has vanished from them.

    Many thanks
    Horizon
     
  2. Digital Doctor

    Digital Doctor Tazmanian

    4,844
    397
    +1,812
    Did you forward the vB5 links to WBB ?
     
  3. Digital Doctor

    Digital Doctor Tazmanian

    4,844
    397
    +1,812
    Does google webmaster tools show you errors ?
     
  4. Horizon

    Horizon Aspirant

    40
    13
    +34
    Only after about three weeks after the software change and I am still not sure if my .htaccess file is correct or not. It's all gobbledygook to me.
     
  5. Digital Doctor

    Digital Doctor Tazmanian

    4,844
    397
    +1,812
    Ask WBB to help.
    Xenforo provides that help.
    You need more skills as a webmaster.
    Maybe pay someone to help you.
     
  6. Digital Doctor

    Digital Doctor Tazmanian

    4,844
    397
    +1,812
    Do you have GWT ?
     
  7. Horizon

    Horizon Aspirant

    40
    13
    +34
    I don't understand Google Webmaster tools at all.

    The first thing it says when going into Google Webmaster tools is this:

    Googlebot found an increase in authorization permission errors on https://www.forumbox.co.uk/
    View details
    Jun 14, 2017

    When I clicked on details before, I just cleared any errors I found as most of them related to the time prior to the software change, so I didn't think they were relevant.

    As of right now, this is what it says when I click on View details:
    =====

    To: Webmaster of https://www.forumbox.co.uk/,

    Googlebot has identified that an increased number of URLs on https://www.forumbox.co.uk/cannot be accessed without permission. Specifically, these pages either present a login page or return a forbidden response code (HTTP 403). As a result, users might not be able to access your content at all, and Google might not be able to show your pages.

    Recommended Actions:
    1
    Identify blocked URLs

    Open the Crawl Errors report in your Search Console account to review the errors reported for your site’s URLs.

    Check Crawl Errors
    2
    Fix the issue

    Check your CMS settings and your server settings to make sure that they’re not returning a forbidden response code (HTTP 403) to fetch requests. You may need help from your server administrator or hoster for this step.

    3
    Verify the fix

    Once you've fixed the URLs with errors, make sure that Googlebot can access and see your content properly.Verify this using Fetch as Google.

    Fetch as
    ======

    What am I supposed to make of that gibberish?
     
  8. Digital Doctor

    Digital Doctor Tazmanian

    4,844
    397
    +1,812
    Does TAZ have a guide for this newbie webmaster ? Or is all the information locked in useless non-threaded threads ?

    Please don't answer.
     
    • Something Fishy! Something Fishy! x 2
    • List
  9. Horizon

    Horizon Aspirant

    40
    13
    +34
    I asked WBB for help, they wern't very helpful. I've posted a message on their forum again.

    I know I need more skills, how can I learn??

    Would someone on here help, if I paid them? What do you reckon that might cost?
     
  10. Horizon

    Horizon Aspirant

    40
    13
    +34
    I'll answer.

    Although there is a getting started forum, it doesn't tell you what steps you need to actually do to set a forum up, only gives general info. This is helpful, but there needs to be more. This is the thread:

    https://theadminzone.com/threads/building-a-new-forum-following-11-useful-tips.141573/

    I am struggling just setting up various basic things up, even like sending a marketing type email that TAZ uses to highlight new topics to members. Unfortunately, despite asking, Woltlab don't even have a manual for setting up a forum using their software because it's so "easy" to do. Easy, if you know what you are doing..:rolleyes::(

    I can see why all the youngsters go to Facebook.... but I'm not a youngster, as my waistline and grey hairs keep reminding me!:)
     
    Last edited: Jul 20, 2017
  11. BrandonSheley

    BrandonSheley loving life

    2,586
    1,072
    +844
    • Informative! Informative! x 2
    • List
  12. Horizon

    Horizon Aspirant

    40
    13
    +34
    Thanks for those links Brandon.
     
    • Like Like x 1
    • Appreciation Appreciation x 1
    • List
  13. MarkFL

    MarkFL La Villa Strangiato

    729
    382
    +864
    Are you thinking of gathering all the relevant information together into a well-written article?
     
  14. Horizon

    Horizon Aspirant

    40
    13
    +34
    The 11 useful tips is a good start, but it needs to be expanded on. I'd write it myself, except I don't know how to set up forums, hence, was I was asking here!
     
Verification:
Draft saved Draft deleted