Chrome & Edge Browser Autofill Anomaly

Discussion in 'Internet and Technology' started by Jim McClain, Oct 3, 2019.

  1. Jim McClain

    Jim McClain Senior Citizen

    1,980
    832
    +644
    Starting today, every time I want to edit a user of my forum while using the Chrome or the Edge browser, the username and email address switches before my eyes to my user name and email address. I checked the Autofill settings and turned them off, restarted the browser, even restarted my computer, but it keeps happening. It does not happen with Firefox browser. The screenshot is from the Chrome browser.

    Look at the breadcrumb navigation; it shows I am in user epoxyman's file, but the heading has changed to "Edit User: Jim McClain" and the form fields for name and email address have changed to my own.
    xf-edit-user1.jpg

    Is anyone else having this problem? Any ideas how to solve it? My browser of choice is Chrome. I don't like having to switch to Firefox when I have to edit members. I've searched Google, but don't find a similar issue.
     
  2. doubt

    doubt Tazmanian

    4,802
    562
    +2,063
    Do you use some password manager?
     
  3. zappaDPJ

    zappaDPJ Administrator

    6,879
    1,432
    +5,490
    I actually used to have the exact same problem in Firefox. If I recall correctly I was able to remove/delete the unwanted auto-fill manually for each field which was tedious but then a later release fixed the issue.

    I've no idea at all if this will work in Chrome but you could try highlighting the unwanted auto-fill and shift-delete.
     
  4. Jim McClain

    Jim McClain Senior Citizen

    1,980
    832
    +644
    Yes, LastPass. Been using it for years. But LastPass has a tiny icon in every form field it controls and there is no icon in either of those form fields. But I have discovered that the problem appears to be from LastPass because signing out of LP stops the autofill of those fields. That means, though, I will have to have LP on to log into the ACP, then turn it off and then I can edit a member. That's some hoops to jump through.

    Shift-delete just empties the fields. I can't save any edits after that without having a user name and email in those fields, which is impossible because I don't know what the member's email address is.
     
  5. Jim McClain

    Jim McClain Senior Citizen

    1,980
    832
    +644
    I just contacted LastPass support. I'll update this thread if I hear back from them. If I don't hear back in a reasonable time period, I should look for a new password manager. Any suggestions?
     
  6. Solidus

    Solidus Stupid machines!

    594
    287
    +334
    Lastpass doesn't do that for me.
    You can go into the settings of a website in Lastpass and disable autofill though, it's under advanced settings.
     
  7. overcast

    overcast Adherent

    309
    45
    +72
    For some reason I just don't trust password storage and auto fill functionality of any browser.
     
  8. Jim McClain

    Jim McClain Senior Citizen

    1,980
    832
    +644
    I think I mentioned that I disabled autofill. Didn't help. I believe it's not the browser, it is the LastPass extension. Logging out of LastPass makes the problem go away, but it also makes all the benefits of having LP go away too.
     
  9. Steve

    Steve Administrator

    3,721
    1,662
    +3,192
    Sometimes password managers are just a PITA, it’s a love hate relationship for me mostly...

    I use Dashlane but have had nearly the same issues in the past, I’ll check later to see if it’s still happenin.
     
  10. MagicalAzareal

    MagicalAzareal Magical Developer

    455
    332
    +211
  11. Jim McClain

    Jim McClain Senior Citizen

    1,980
    832
    +644
    The templates have not been changed in some time, so I am reluctant to change them to ostensibly correct a behavior that just happened a week ago. I don't know what could have caused this problem to occur. It couldn't be XF because there has been no upgrades recently. It could be the Chrome browser, if it has been updated in a background process that I am unaware of. Likewise, it could be the LastPass extension has recently been updated without my knowledge (but why wouldn't that also affect the Fireworks browser form fields).

    I've been going back and forth with LastPass support (LogMeIn) and they have offered no clues and finally suggested I turn LP off for my forum - that bit of advice came from a "higher level" support tier person. I am not interested in that solution, nor am I willing to continue to switch back and forth between my preferred browser, Chrome, to the Firefox browser, which is the only browser that doesn't exhibit this issue, whenever I need to edit a member.

    I think it's time I explore other password managers.
     
  12. BrandonSheley

    BrandonSheley loving life

    2,604
    1,072
    +950
    Browsers these days have their own built-in password managers..

    Here is the setting on chrome.

    auto.PNG
     
  13. Jim McClain

    Jim McClain Senior Citizen

    1,980
    832
    +644
    I would never trust a browser to manage my passwords. Too many fingers in too many pies.
     
  14. BrandonSheley

    BrandonSheley loving life

    2,604
    1,072
    +950
    Eh.. each to their own
    I don't use the one in chrome, I've been a fan of LastPass for a while.
    I'm just saying that this sounds like the browser is auto-filling your fields.
    I see you said you cleared it, but it's what it sounds like to me.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.