SSL cannot login to newly secured site

Discussion in 'Domains and SSL Certificates' started by henryimosey, Oct 7, 2017.

  1. henryimosey

    henryimosey Aspirant

    10
    1
    +0
    I have just secured my site with Comodo CA.
    However, now when I try to login to the site I get an "insecure site warning" and a "You don't have permission for that" warning
    I am admin.
    what do I have to alter please?

    https://www.spywareinfoforum.com/
     
  2. Steve

    Steve Administrator

    3,184
    1,472
    +2,623
    Try using a different browser to rule out cookie/cache issues.
     
  3. Tracy Perry

    Tracy Perry Opinionated ass-hat

    4,398
    412
    +2,966
    Insecure content is from this

    Screen Shot 2017-10-07 at 10.36.48 PM.png

    If you have recently moved over to SSL on the IP.Board setup you need to make sure your ACP reflects the new HTTPS and I think there is also a setting in the conf_global.php base_url is also changed to HTTPS (that is where it is in IPS 4.2).
     
  4. henryimosey

    henryimosey Aspirant

    10
    1
    +0
    Thanks. Tried clearing everything on 4 different browsers.

    thanks. That's what I thought as well so I cleaned that up and the mark on the circled i disappeared. I'll have another look at conf-global.php
     
  5. henryimosey

    henryimosey Aspirant

    10
    1
    +0
    As I couldn't fix the problem I used a backup and reverted the site to http.
    Now can I please get some help on what steps I should take to ensure this does not happen again when I reinstall Comodo CA.

    Our host is Host Winds
    IPB 3.4
    1 domain - 6 subdomains
    I have ftp access to CPanel.

    Thank you
     
  6. Tracy Perry

    Tracy Perry Opinionated ass-hat

    4,398
    412
    +2,966
    One thing to make sure of... if any (or all) of the 6 sub-domains are tied in any way to the IPS install on a main domain, they will need to have SSL certs also.
     
Verification:
Draft saved Draft deleted