Any hosts still have old MySQL?

Discussion in 'Hosting Discussions' started by Pete, Jun 11, 2018.

  1. Pete

    Pete Flavours of Forums Forever

    1,682
    227
    +542
    Anyone know if any hosts still provide MySQL below 5.5 on their hosting?

    Looking to kill some legacy code and it would sure be nice if I knew older versions of MySQL were dead and buried.

    I know XF 2 requires 5.5.x these days, so I'm assuming it's probably a safe bet that only rubbish hosts still have this - heck, even 000webhost is in the modern age now with MariaDB 10.
     
  2. we_are_borg

    we_are_borg Moderator

    4,277
    777
    +1,648
    With a VPS you should be able to do it your self.
     
  3. Pete

    Pete Flavours of Forums Forever

    1,682
    227
    +542
    I specifically asked about this because I'm building software that I'm giving away to other people, where I don't get to choose the server...
     
  4. we_are_borg

    we_are_borg Moderator

    4,277
    777
    +1,648
    If you cant find a host that has 5.5 as default why not use a higher version, you can not please everyone.
     
  5. Pete

    Pete Flavours of Forums Forever

    1,682
    227
    +542
    I'm trying to see if any hosts are still using old software - if they're not using old software, I can remove all the old code for old versions, that's why I care and why I'm asking.

    The hosts I've already looked at all use 5.6 or 5.7, which is fine - I just need to know that people are on 5.5 or better and I was hoping that people might know of hosts that still run old software (that they might be stuck on)
     
  6. KnownHost

    KnownHost Sponsor

    64
    23
    +50
    I'd say most hosts should be at least on 5.5 by now, but likely most are 5.6 and higher. Esp cPanel hosts which defaults to the higher versions now.

    If you want to be *safe-ish* you can use the EOL dates and add a bit of time depending:
    http://www.fromdual.com/support-for-mysql-from-oracle

    Technically 5.5 is still being supported until December 2018 so it's not officially dead just yet but everything below it is dead for a long time now.
     
  7. Maddox

    Maddox Moderator

    1,058
    387
    +775
    I'm on 1and1 (who doesn't already know lol) and they are running 5.5 on their shared packages - I've asked them many times when they will upgrade to a newer version but there is just stoney silence; I don't know how major a job it is to upgrade on hundreds of servers for a hosting company.

    There are a few that I have researched who run higher versions, but not many.

    ;)
     
  8. Pete

    Pete Flavours of Forums Forever

    1,682
    227
    +542
    Seems like it's only supported in extended support, not general support - and I don't believe most hosts would be paying for that, but my key barometer is 5.5.3+ and if 5.5 is headed out to EOL very soon that seems to support my stance that I can ditch the utf8mb4 compatibility stuff I originally wrote years ago and just roll with it.

    Thanks for the link - it definitely reaffirmed my philosophy of making StoryBB 7.0+ only, but there's no mention of MySQL in that thread :(
     
  9. vbgamer45

    vbgamer45 Enthusiast

    225
    63
    +55
    7.0+ for php is the way to go. I think there would be very few hosts still offering 5.1 MySQL.
    And if you are targeting 7.0+ those hosts wont' have the old Mysql version. 5.5 has been around since 2010
     
    • Informative! Informative! x 1
    • List
  10. Pete

    Pete Flavours of Forums Forever

    1,682
    227
    +542
    That's what I thought, thanks :)
     
  11. djbaxter

    djbaxter Tazmanian Veteran

    10,406
    917
    +405
    There seem to be quite a few shared hosts and even managed VPS still using PHP 5.6.x, though. And if you browse vBulletin.com at all, that seems to be the case for a lot of vBulletin forums.

    I guess it would depend on the customer base for your software,
     
  12. Pete

    Pete Flavours of Forums Forever

    1,682
    227
    +542
    It's free software so it's not like I'm worried about losing potential paying customers, just wanted to be sure I wasn't unreasonably cutting off possible users without at least considering the state of the hosting situation.
     
  13. HD-Sam

    HD-Sam Neophyte

    9
    56
    +6
    You'd be surprised how often we migrate clients that were running 5.0 or 5.1. Most of them however are operating their own servers and haven't updated. With that said, KnownHost is spot on. Almost everyone is on 5.5 or greater.

    djbaxterdjbaxter On PHP 5.6, the same is also true. There are some whose addons/plugins require the older versions (more common in shared environments), but man are they missing out.
     
  14. MikeDVB

    MikeDVB Fan

    663
    295
    +46
    Personally I'd just list the requirements of your software as needing MySQL 5.5+ with a recommendation of MariaDB 10.10+.

    If you're going to make changes that could cause issues for existing clients/users of your software I'd try to give a month or two of advanced notice - a few warnings - to give them a chance to do something about it before their software suddenly stops working.
     
Verification:
Draft saved Draft deleted
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.