All pages returning 'The requested URL was not found on this server' [Wordpress]

Discussion in 'Blogs, Wikis, and other CMP's' started by Manberlin, Jun 16, 2017.

  1. Manberlin

    Manberlin Not Manbearpig

    It's been a while since I've been on TAZ! [edit: so long that I apparently forgot to post this in the right sub-forum]

    Recently (about 15 minutes ago) one of my Wordpress installations began to return the following error message on all of our pages, including the login and admin pages:

    Not Found
    The requested URL /collegetown-gives-students-something-think/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    Apache Server at Port 80
    I have not changed anything on the website today, and it was working earlier. We haven't touched the permalinks setting in years which I know is usually the cause of this. The site is on shared hosting (wasn't my choice :)), which means I am unable to edit the httpd.conf file, and my .htaccess file already contains the following:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
    That did not seem to change anything though. Any help would be greatly appreciated!
    Last edited: Jun 16, 2017
  2. Tracy Perry

    Tracy Perry Opinionated ass-hat

    Anybody been playing around in cPanel that shouldn't have been? That almost looks like there is a mis-configuration issue for that "domain".
    If not, I'd be conversing with my hosting provider letting them know that nothing has been changed and all of a sudden the site quit working and ask if they had made any "upgrades" on their end.
  3. Lisa

    Lisa The Black Widow

    Is the Slope Media url the one you're referring to? If so, then I'd say the warnings at the top of the blog referencing missing files for WP Cache might have something to do with it.

    wp cache.png
  4. Manberlin

    Manberlin Not Manbearpig

    I specifically addressed that trying those specific solutions did not work, in my original post. Those were the very first things I tried.

    As far as I know, I am the only one who has knowledge of our account information beyond a few people from years' past. Going through the cPanel and file manager I did not see any obvious changes.

    Correct, the Slope Media url. This new error message is something that began to appear this morning after I talked with support and they asked me to switch off our Cloudflare nameservers to the default ones. I get it on my phone but not my laptop so I assume that's a caching issue right now.

    Afterwards, the direct link to the admin panel did not load at all, but I could reach the login page. However, after trying to login I received an error "Cookies are blocked due to unexpected output." Couldn't figure out how to tackle that one, so I disabled WP-Super-Cache from phpMyAdmin and the site is at least working on my mobile device now. Cleared Safari and Chrome's cache (and my DNS cache) but still seeing the 404 pages on the desktop -- will give it a bit of time and see but I think the problem is fixed now. Appears the root issue was the WP-Super Cache plugin for some reason, compounded by the Cloudflare nameservers.
  5. Manberlin

    Manberlin Not Manbearpig

    EDIT: Okay, getting the same error all over again -- didn't activate WP Super Cache or anything again. Not sure why it was working for a few minutes and then stopped.

    Cache finally cleared and the site is working again! Albeit slower now that I had to take off Cloudflare, WP Super Cache and reset our htaccess to the basics.

    So I know what caused it, just not the why, so it looks like I'll have to do some digging.
    Last edited: Jun 17, 2017
Draft saved Draft deleted