MySQL FYI, MySQL 8.0 doesn't support minor version downgrades anymore

eva2000

Habitué
Joined
Jan 11, 2004
Messages
1,752
This is a public notice to let folks know that if you're using Oracle MySQL 8.0 or Percona MySQL 8.0 versions, that even minor version downgrades are not supported anymore unlike on MySQL 5.7 and below and MariaDB 10.4 and below. So you can't rollback/downgrade from MySQL 8.0.18 to 8.0.17 easily anymore without doing a full all database backup restore from a prior minor version upgrade backup. You'll have to backup not just your web app databases but system MySQL databases too (basically all databases on the server).

Which means it's more important to have regular full all databases on server backups as only way to downgrade even MySQL 8 minor versions i.e. 8.0.18 to 8.0.17, is do to a full all databases on server restore from pre-upgrade backups !

Info Links
My Centmin Mod forum user's discussions
Centmin Mod 123.09beta01 and newer officially only support MariaDB MySQL servers from 5.5, 10.1, 10.2, 10.3 and 10.4. With planned support for Oracle MySQL 8 and Percona MySQL 8 way into the future as outlined in dev dashboard at centminmod/centminmod.
 
Top